Timeline of a failed Hard Drive

I’ve been getting random, non-descript BSODs for over 3 years now. Hey, no big deal Windows is just a buggy POS, I’d learnt to live with it. Only recently, sessions began lasting for less and less time. To the point last month, where sessions would last 30 minutes before crashing which was incredibly frustrating. I trawled the Web trying to decypher these cryptic bug check codes, as though I was Howard Carter trying to decode hieroglyphics. No such luck. Time and time again, WhoCrashed just said it was a software problem with the Windows Kernel and unlikely to do with a hardware issue.

With Windows shortly losing support for updates anyway, I thought it was time to cut my losses and make the inevitable transition to Linux. I’d stopped gaming seriously anyway. Plus I heard there was this new fangled support called proton which lets you play Steam games with built in WINE support. Luckily I had a Ubuntu partition, which I could easily dual boot into. It seemed to work fine. Only after a restart, something would break, (possibly related to updates?) and I wouldn’t be able to boot into Ubuntu. I can’t remember exactly but I think even GRUB was fucked. No biggie, I’ll just restore the install from Clonezilla and not update anything. Only, it would forcibly install downloaded updates after shutdown. A fresh install of Debian also failed.

Fine, have it your way, back to Windows then. So I got another BSOD, only this one was different. There was a more descriptive error message, something about the NTFS driver. Oh, it was a HW problem after all. Had my HDD failed? Checking the symptoms on the Web, they certainly correlated with a failed drive. Shit, guess I need a new one. Wait, I could be wrong, more testing required.

So I tested the drive under S.M.A.R.T., and it came back clean but a friend told me that S.M.A.R.T. is notoriously unreliable and to verify by other means. So I put Seatools onto a live USB (if anyone knows about failed HDDs it’s SeaGate) and ran the tests. On the first occasion, something crashed after 15 minutes and I had to restart. So I ran it again, this time for 6-7 hours and it came back clean. Hmph, inconclusive. So I did some checking in a Linux terminal but I didn’t really know what I was looking at, it seemed fine. I guess it could be the RAM? So I ran memtest for 10 hours and 5 passes and it came back clean. Ideally you’re supposed to run it for 8 passes but who’s got time for that? RAM is generally pretty robust anyway.

Next I thought of a test that would conclusively tell me if it was the HDD or not. I put in an old Win XP HDD into my computer to see if that would crash or not. It ran absolutely flawlessly. I was surprised how quick it was. Seeing the splash screen always made me laugh and I was impressed at being able to remember a password I thought up 4 years ago. Ok then, time to order a new HDD then. Might as well get a beefy SSD if I’m doing this properly. I managed to get a good deal from an arcane company, matching the Amazon price thankfully (fuck Amazon). I selected free standard delivery but it arrived the next day anyway, what a pleasant surprise.

I wanted to make a clean break. So I’d image my windows partition and just have it as a backup OS and use Linux mainly. The imaging failed under Clonezilla (that’s 2 hours wasted then), likely due to bad sectors. So then I ran CHKDSK, which merely confirmed the drive had failed. Great. Fine then, let’s image Ubuntu onto the SSD and just use that for the time being. I’ll worry about the data later. Same problem as before, after one reboot it would shit itself. Fine it’s probably just a fucked up install of Ubuntu or Ubuntu being shit. I’ll do a fresh install of Debian. Same problem. What the fuck is going on?

Have they sent me a faulty SSD? Highly unlikely as they’re so robust with no moving parts. Has something else failed and I’ve wasted $200 on an SSD? Is it the MOBO? Is it the SATA controller? Is it the cable? I tried a fresh Manjaro and Ubuntu install, same thing. It’s a shame because Manjaro looked super cool too. There was nothing in /var/log. It was something to do with Nvidia GPU drivers not playing nicely with Linux. Even during my attempted resolution, it crashed. Open sores at its finest. What the fuck do I do now?

Resigned to my fate I just went back to using Windows. So what if the problems with Linux were simply incompatibility with my GPU drivers? If that was true, then Windows should work fine. So I could do a fresh Windows install and test it but I’m lazy. Ok, what if I use a disk to disk clone in Clonezilla to restore my Windows installation? It wouldn’t let me do it. So I made a Windows PE environment which included BOOTICE. I used that to restore an AOMEI backup I had just created and it worked great! Now more than ever I was convinced the SSD was fine. The software even optimized the SSD sectors for speed too. So I lasted on this set up for about a week. I still didn’t have my data partition. So I used AOMEI backupper to do a partition clone. It took about 9 hours but it worked out fine. Only for some reason BCD shat itself. Good thing I had the foresight to have BOOTICE on the Live USB. So I reinstalled BCD and everything was fine.

Moral of the story? Open Sores is bad. Fuck computers.

Leave a Reply

Your email address will not be published. Required fields are marked *